Dans cet article, vous découvrirez :
Sites protégés par WEDOS
WEDOS Protection sert principalement à protéger les sites web et, à travers eux, l’infrastructure d’hébergement web sous-jacente contre les attaques et autre trafic indésirable. Cela est réalisé par :
- Filtrage du trafic suspect selon l’IP ou le comportement. WEDOS Protection évalue tout le trafic à l'aide d'un algorithme complexe. Si certaines méthodes et voies d'attaque sont assez évidentes, d'autres se déguisent pour paraître aussi légitimes que possible afin de se fondre dans la masse des robots utiles et des vrais visiteurs du site. Comme il vaut mieux prévenir que guérir, le système peut parfois bloquer du trafic non malveillant et rendre un site indisponible pour un certain groupe de visiteurs ou de services.
- Distribution du contenu mis en cache. Pour réduire la charge des serveurs, WEDOS Protection met le contenu en cache, ce qui peut entraîner l'affichage de versions obsolètes du site, notamment si le contenu mis en cache est demandé très fréquemment. Pour plus d'informations, lisez Protection – Cache CDN article.
- Masquer le serveur web derrière un proxy. L'adresse IP du serveur d'un site protégé doit être complètement dissimulée d'Internet et remplacée par l'IP du serveur proxy WEDOS Protection. Cela peut toutefois poser problème si un service doit vérifier que l'IP d'hébergement correspond aux enregistrements du domaine concerné. Pour plus d'informations, consultez le Protection – DNS et IP cibles article.
- HTTPS. Le système impose l'utilisation du protocole sécurisé HTTPS (HTTP over SSL) et peut provoquer des erreurs si le chiffrement échoue à un moment quelconque.
Vous activez généralement la protection et les autres avantages de WEDOS Protection en ajout de votre domaine, mais WEDOS peut également déployer une version d'urgence dans des cas justifiés.
WEDOS Global d’urgence
Lorsqu’un site non protégé, exploité principalement sur un service d’hébergement web mutualisé, devient la cible d’un trafic problématique ou d’une attaque qui menace d’autres parties de l’infrastructure en dehors de ce site, nous devons limiter les dégâts en restreignant fortement ce site problématique, parfois même en le coupant complètement. Cette solution est désavantageuse tant pour nous que pour le client.
WEDOS Protection nous permet d’éviter les restrictions d’exploitation grâce aux mécanismes indiqués ci-dessus, qui protègent le site lui-même ainsi que toute l’infrastructure associée, car l’attaque doit désormais passer par un proxy correctement équipé pour y faire face, tandis que le serveur web dispose de ressources libres pour faire ce pour quoi il est prévu.
Pour déployer cette protection, le domaine d’hébergement web doit utiliser Serveurs WEDOS DNS ⧉. En cas d'urgence, un technicien modifiera les enregistrements DNS du serveur web vers le proxy WEDOS Protection dans notre système, ce qui résout généralement le trafic indésirable en quelques minutes et peut lever d'éventuelles restrictions d'hébergement.
Nous informons les clients de la mesure prise par un message envoyé à leur adresse e-mail de facturation.
Bien que la protection d’urgence WEDOS Protection soit techniquement gratuite, elle présente ces inconvénients majeurs :
- Aucun contrôle du client sur les paramètres de WEDOS Protection. Sauf si les clients achètent eux-mêmes WEDOS Protection, ils n’ont pas accès aux commandes.
- Les éventuels problèmes sont traités par le support client avec une priorité faible. Le délai de réponse habituel en cas de problème de contenu est de 2 heures ; il peut être nettement plus long les week-ends et jours fériés.
Pour profiter gratuitement des avantages de WEDOS Protection, sans les inconvénients de la version d’urgence, ajoutez le domaine via notre plugin WordPress.
Le déploiement d’urgence de WEDOS Protection peut provoquer des erreurs. Les plus courantes, ainsi que leurs solutions, sont décrites dans Dépannage chapitre.
Résolution des problèmes courants
Les problèmes courants des sites utilisant WEDOS Protection, que ce soit en tant que service autonome ou en version d’urgence déployée par nos soins, sont notamment :
- Messages d’erreur
- Contenu du site web endommagé ou non fonctionnel
- Accès bloqué aux contenus et API tiers
- E-mails envoyés depuis le web marqués comme spam ou non délivrés
Messages d’erreur
Problème : Un message d’erreur s’affiche sur le site web.
Solution : La solution correcte dépend du message d’erreur affiché :
- Introuvable sur l’accélérateur. Vous rencontrerez le plus souvent cette erreur si HTTPS n’est pas configuré sur votre hébergement web VEDOS. Vérifiez les paramètres du domaine dans le certificat selon le Hébergement web – Configuration manuelle du HTTPS ⧉ guide. Si HTTPS est désactivé, activez-le. En cas d’erreurs avec les domaines, contactez le support ⧉ et demandez l’ajout de (sous-)domaines avec validation désactivée.
- Introuvable (404). Cette erreur est due soit à des paramètres HTTPS incorrects sur le serveur cible (voir ci-dessus), soit aux IP du reverse proxy WEDOS.protection. Dans ce dernier cas, assurez-vous que vos IP proxy correspondent à celles définies dans le DNS du domaine.
- Gateway Timeout. Assurez-vous que votre serveur ne bloque pas les connexions vers les adresses de cette liste ⧉ (Version JSON ⧉).
Contenu du site
Problème: Le site ne s’affiche pas correctement, voire pas du tout, après le déploiement de WEDOS Protection. Parfois, seule la page principale ou certaines sous-pages fonctionnent correctement.
Cause: Le problème est généralement dû à une erreur de mise en cache du contenu statique, mais il peut aussi être lié à blocage des templates, plugins et ressources externes décrit ci-dessous.
Solution : Si vous avez accès au Panneau d’administration WEDOS Global ⧉, videz le cache ou réinitialisez-le (désactivez puis réactivez) dans le Cache CDN paramètres.

Si vous n’avez pas accès à l’administration WEDOS Global, vous pouvez ajouter le domaine et obtenir l’accès, ou demandez-nous de purger le cache ⧉. Les demandes sont généralement résolues par le service technique sous 2 heures, selon la charge de travail du service et la complexité de la solution (surtout si le problème se situe ailleurs).
Blocage de contenus externes
Problème: Après le déploiement de WEDOS Protection, un thème, une extension ou un service/API tiers (robots d’exploration, passerelles de paiement, etc.) ne fonctionne pas correctement.
Cause: WEDOS Protection peut bloquer préventivement de larges plages d’adresses IP, par exemple sur la base d’une mauvaise réputation. Entre ces plages peuvent toutefois se trouver quelques adresses sans problème utilisées par des plugins, des templates et, plus généralement, des API avec lesquelles votre site doit communiquer, mais ne le peut pas.
Une autre cause fréquente du problème est la restriction d’accès à une application ou une interface tierce que vous aviez initialement configurée pour l’IP du serveur d’hébergement web. Or, après le déploiement de WEDOS Protection, vous y accédez depuis l’une des nombreuses adresses IP régionales du système.
Solution: Demandez au support du tiers bloqué de fournir la liste complète des adresses IP que nous devons ajouter à la liste blanche de notre côté afin de rétablir la communication. Il doit s’agir d’adresses précises et unitaires – de grandes quantités ou des plages entières posent généralement problème.
Une fois cette liste obtenue, envoyez la requête suivante ⧉:
Please whitelist the IP addresses (replace the parenthesis with a list of addresses) in the WEDOS Protection system in order to restore the connection of the website (replace the parenthesis with the name of your website) with the service (replace the parenthesis with the name of the template, plugin, API or other setvice that cannot connect).
Les demandes sont généralement traitées par le service technique sous 2 heures, selon la charge de travail du service et la complexité de la demande (vérification de la réputation de l’adresse IP).
Si, à l’inverse, la source du problème est une connexion bloquée sur un serveur tiers (généralement des passerelles de paiement), autorisez la communication pour les adresses IP de la liste disponible sur https://ips.wedos.global/ips.json ⧉ (mise à jour automatique).
Distribution des e-mails
Problème: Les e-mails envoyés depuis le site web (par exemple les formulaires) arrivent dans les spams ou ne sont pas distribués du tout.
Cause : La cause la plus fréquente est un problème de vérification de l’enregistrement SPF dû à une différence entre l’enregistrement A du domaine et l’adresse IP réelle du serveur web.
Solution: Ajoutez l’adresse IP réelle de l’hébergement web à l’enregistrement SPF du domaine à l’aide du code ip4:X.X.X.X. Vous trouverez des instructions détaillées dans l'article E-mails – enregistrement SPF ⧉.
FAQ
Que faire si le domaine d’hébergement web attaqué utilise des serveurs DNS tiers ?
Dans ce cas, un technicien tente de contacter le propriétaire par e-mail et par SMS. Tant que nous ne pouvons pas protéger efficacement le service, nous en limitons les paramètres ou l’arrêtons complètement.
Comment savoir qu’un site utilise WEDOS Global ?
Vérifiez les enregistrements DNS A. Si vous trouvez deux valeurs 45.138.107.X, où X est un nombre compris entre 0 à 255, le domaine redirige vers WEDOS Protection.
Pour les enregistrements AAAA, la valeur correspondante est 2a0e:acc0::X.
Que faire si j’ai un autre problème ou si votre solution ne fonctionne pas ?
Pourquoi configurer WEDOS Global alors que je suis déjà protégé par un autre service ?
Nous recevons un volume important de trafic indésirable, même depuis des domaines utilisant d’autres services de protection. Dans certains cas, si nous ne pouvons pas activer WEDOS Protection pour un site attaqué, nous n’avons d’autre choix que de limiter/désactiver l’hébergement web.
